SimplyCool

 


Go Back   Official Scythe Forum > Scythe Fans > Grand Flex Series

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 01-09-2017, 06:18 PM
Junior Member
 
Join Date: Jan 2017
Posts: 1
Default Grand Flex PWM Grinding/Clicking noise

Hello, i have purchased two Grand Flex's to use on my radiator almost 2 weeks ago, i was very happy about them but after about 20 minutes one of the fans started making gridning/clicking noises, i pulled it out and let it run unmounted - same story. It stopped making noise only after it was orientated to push the air upwards, it was making the most noise when pushing air downwards, horizontal/vertical noise was obnoxious too.

I filled an RMA and got a replacement fan, it ran good for 5 minutes until it started clicking slightly, i pushed it to 2000RPM and it stopped, then after running at 900 RPM of a little bit it started making more and more noise so i finally decided to pull it out. There was a bit of plastic stuck in the middle of the rotor, i removed it and reinstalled the fan onto my rad. It was silent, then again, ran for 10 minutes and started clicking at 900 RPM, then it was ok for 20 minutes at 2000RPM, now it makes noises at all RPM's and at 900 RPM i can hear it over anything in my room, constant clicking/grinding - you name it.

I am stuck, i have 2 days to return it to the store within the 14 day return policy, i like the one fan that works, i don't want to, i would also have to return other stuff i bought with the fans which sucks. If this is not solved until then i will be forced to do it, get new fans and never even look at Scythe products ever again, i don't want to waste 20$ on fans.

I really love the fan that works, it just sucks that i can't get a second that isn't broken.

I have two videos illustrating the issue, the top fan is the new replacement fan which is the one that's broken, the bottom one is the original of the two i bought that never had any issues:

1st Video - Bottom Grand Flex running at 2000RPM, Top Grand Flex (The broken one) 900 RPM
https://www.youtube.com/watch?v=DD14lC9HeUI

2nd Video - Bottom Grand Flex running at 900RPM. Top one at 2000RPM - the clicking/grinding noise is insane
https://www.youtube.com/watch?v=agtSwX1Yok4

Is it a recent, really bad batch of these fans? 2 out of 3 broke after less than 30 minutes.

Last edited by JakeT; 01-09-2017 at 06:21 PM.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


 
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
Template-Modifications by TMS
Copyrights by Scythe EU GmbH - All rights reserved - 2007

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61